Itron meter delay
Incident Report for AlsoEnergy
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 06:50 PDT
Investigating
We are investigating an issue that is causing Itron meter data to be delayed. We will provide more updates as they are available.
Posted Oct 18, 2020 - 19:43 PDT
This incident affected: LocusNOC (Data Acquisition).