delays to ingest powertrack

Incident Report for Stem

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 18:53 PDT

Identified

Our dev team has identified the issue and are working toward a resolution.
Posted Aug 20, 2026 - 11:49 PDT

Investigating

We are investigating an issue in Powertrack, this may cause some delays in ingest.
Posted Aug 20, 2026 - 09:25 PDT
This incident affected: PowerTrack US (Data Ingest).