Data Delay from CatM Meters

Incident Report for Stem

Update

We are actively working with our vendor partners to upgrade the CatM data processing infrastructure. We appreciate your patience as we work to improve performance.
Posted Jun 15, 2026 - 07:28 PDT

Identified

We are currently working on resolving the data delay with our CatM Meters. We thank you for your patience as we work to resolve this issue.
Posted Jun 10, 2026 - 15:08 PDT
This incident affects: LocusNOC (LGate).